是非とも見なかったことに…
スポンサーサイト

一定期間更新がないため広告を表示しています

- - -
ubuntu firefox 3.6
ubuntu 9.10 の firefox 3.5, 3.6 で起動直後しばらくマウスが砂時計のままになる現象が軽くウザかったんですが、別件で環境変数を設定したら直ったのでメモ

% sudo vi /usr/bin/firefox
: export GDK_NATIVE_WINDOWS=1 :

つべの埋め込み再生時の不具合も直って素晴らしい。
Linux - -
Ubuntu 9.10 gedit 〜文字
utf-8 環境な ubuntu 9.10 上の gedit で SJIS なテキストファイルに「〜」を入力して、保存しようとすると「無効な文字が〜。現在のロケールで〜。」とエラーが起きて保存できません。
ubuntu 9.10 というか ibus-anthy が「波線」だろうが「波線ダッシュ」だろうが「波線ダッシュ」で入力してしまうため utf-8 <=> SJIS 変換ができずにエラーが発生してしまうようです。
これを回避するためには gedit で SJIS ファイルを開く際、SJIS で開くのではなく CP932 で開くと万事OKです。
Linux - -
ubuntu 9.04 install trouble
たぶんレアケースなので多くの人には参考にならないことを先に宣言しておきます。

構成は KVM 接続の
M/B: FIC の何かで ICH4 chipset (old Phoenix BIOS)
CPU: Celeron 2.2GHz Northwood
MEM: 128MB -> 2GB
VGA: Intel 845G & GeForce FX 5200 PCI
HDD: IDE 40GB -> IDE 250GB
NIC: 蟹

Ubuntu インストール CD で起動後、インストールを開始させると hardware probe で hang します。
console message
kinit: rc-default main process (XXXX) terminated status 127 or udevd: segmentation fault or none message
と、色々とランダムに変化します。これは結論だけ言ってしまうとケーブルがつながってないグラボがあるので probe に失敗してしまい処理が止まっていたのでした。
BIOS で切り替え不可、更に追加したグラボに最終的に必ず信号が流れる変態仕様な M/B だったので、KVM 外したり USB 切ったりと、ここに辿り着くまでにすごい苦労しました。
この問題を回避するにはインストール CD で起動後 F6 を押して以下を追記します。
add following boot option
intel_agp.blacklist=yes
(「_」が入力できない場合もあるので、そのときは F3 でキーマップを USA にしておきます。どうせインストール中に再度キーマップが選べるので無問題です)

boot 時に intel グラボを殺すことで先に進むことができます。(unknown option hogehoge ignore って言われますが無視しておk) そして滞りなくインストールが完了したら、端末から
% sudo vi /boot/grub/menu.lst
で先の intel_agp.blacklist=yes を追記しておきます。

最近は BIOS でどっちのグラボを使うか選択できるはずなので、多くはこの問題に陥らないと思います。でも、もしもグラボ 2枚差しで ubuntu が起動しないという事が起きたらこれを参考にしてみてください。
Linux - -
apt-get
頻繁に実行しないので良く忘れます。
apt-get コマンド
apt-get update … パッケージリストを更新するよ apt-get upgrade … 既にインストールされてるパッケを最新にするよ apt-get clean … アーカイブを削除するよ apt-get autoclean … 古くて依存関係切れたアーカイブを削除するよ
GNOME はいらないので apt-get remove gnome* して、代わりに apt-get install xfce4-desktop したら結局 GNOME が全部入ったでござる。
Linux のパッケージの依存関係は相変わらず馬鹿というかお節介過ぎるというか 10年以上経っても変わらないなぁと妙に感心してしまうのでした。ライブラリなどコアな部分が数十入るというのは納得できるのですが、全部はいただけないと思うのです。

ちなみに ubuntu (Mem 512MB) by VMPlayer on XP Pro SP3 (PenM 1.2GHz/Mem 1.5GB) でも軽いですね、XFCE4 は。いや言い過ぎか、軽い部類ってとこでしょうか。load average が 0.3 〜 0.7 で xorg の %CPU が 3.0 〜 15%。まぁ余計なプラグインが裏でいっぱい動いているのでこんなもんですかね。
Linux - -
ubuntu apt-get
ubuntu に snort を入れて遊んでいたのですが、遊びすぎて起動しなくなってしまいました。ルールを下手にいじると泣きをみますね。
それで入れ直せばいいや的な軽いノリでいたのですが、ちょっとはまったのでメモ。

% sudo apt-get remove snort
% sudo apt-get install snort

これでは snort の実行ファイルしか削除されず壊れたルールや conf はそのままなので起動しません。それならば

% sudo apt-get purge snort
% sudo apt-get install snort

するも壊れたルールなど残ったままで起動せず。
よくよくみたら、install 時に snort-hogehoge などいろいろな要求ファイルがありました。ってことなので、

% sudo apt-get purge snort*
% sudo apt-get install snort

これで復活できました。
Linux - trackbacks(0)
Install VMware to Ubuntu 7.10 Desktop
Ubuntu に VMware を入れるメモ (超テキトー)

Ubuntu じゃあ rpm バイナリはインストールできないので、、、

1. get VMware-xxx.tar.gz
2. tar zxf VMware-xxx.tar.gz
3. cd vmware-xxx
4. sudo ./vmware-install.pl
:
(上の vmware-install.pl をやれば sudo vmware-config.pl しなくてもおkです)

この方法だと apt-get で管理できてないのでコマンド一発で uninstall できません。
uninstall する場合は、、、

% /usr/bin/vmware-uninstall.pl
Linux - trackbacks(0)
VPC上のfedoraでVMware WKS6
VPC2007上のfedora core6にVMware Workstation 6.0.1入れてみました。
元々vmware-any-any使ってWKS 5.5.3が入っていたので、そのせいか分かりませんが、すんなり6.0.1が入りました。

# yum remove VMware-workstation-5.5.3-xxxxx.i386.rpm
# rpm -i VMware-workstation-6.0.1-55017.i386.rpm
# vmware-config.pl
:
全部デフォルト回答
:
# vmware

とするとGUIが立ち上がります。
Linux - trackbacks(0)
fedoraで無線まとめ
X40(無線のチップがAtheronics?の方)のfedoraで無線を使う方法まとめ

【本体の設定】
・無線をONにしとく

【VPCの設定】
・VPCの「ネットワークアダプタ数」を「2」
・アダプタ1を無線
・アダプタ2を有線

これでデフォルトが有線になるので無線がダメでもネットにつながるっぽい

【fedoraの設定】
#yum install madwifi
/etc/sysconfig/network-script/ifcfg-ath0を作成
#service network restart
Linux - trackbacks(0)
rubyメモ
# rpm -e ruby-xxx
# rpm -e ruby-yyy

./configure --prefix=/usr
make
checkinstall --fstrans=no
rpm -i /usr/src/redhat/RPMS/i386/ruby-1.8.xxx.rpm

ruby setup.rb config
ruby setup.rb setup
ruby setup.rb install
gem update
gem install rails --include-dependencies
Linux - trackbacks(0)
<< | 2/2 |